hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Purtell <apurt...@yahoo.com>
Subject Re: DISCUSS: Have hbase require at least hadoop 1.0.0 in hbase 0.96.0?
Date Wed, 07 Mar 2012 22:32:09 GMT
Thanks Deveraj and Arun. 

The security related APIs should be promoted to public/stable given their increasing adoption.


At least on the HBase side, I'll take the pain once to rework our related sources if the APIs
on their way to stability make one more change. However, it would be preferable to avoid further
need for hacks. Use of reflection can ride over an API in transition, but it can also punt
breakage due to API change to runtime, where we'd least like to see it for the first time.


Best regards,

    - Andy


On Mar 7, 2012, at 10:20 AM, Devaraj Das <ddas@hortonworks.com> wrote:

> Given that the token/ugi APIs are being used in other ecosystem components too (like
Hive, HCatalog & Oozie), and in general, that security model will probably hold for other
projects too, I think that its not an unfair expectation from Hadoop that it should maintain
compatibility on UGI/Token* interfaces (*smile*). 
> 
> On Mar 6, 2012, at 11:57 AM, Arun C Murthy wrote:
> 
>> Andy - could you please start a discussion? 
>> 
>> We could, at the very least, mark UGI as LimitedPrivate for HBase and work with you
guys to maintain compatibility for the future. Makes sense?
>> 
>> thanks,
>> Arun
>> 
>> On Mar 6, 2012, at 10:21 AM, Andrew Purtell wrote:
>> 
>>> After that, I believe we can merge the security sources in. However we may have
an issue going forward because UGI is an unstable/private API. Needs sorting out with core
at some point. 
>>> 
>>> Best regards,
>>> 
>>>  - Andy
>>> 
>>> 
>>> On Mar 6, 2012, at 9:55 AM, Stack <stack@duboce.net> wrote:
>>> 
>>>> On Tue, Mar 6, 2012 at 9:10 AM, Andrew Purtell <apurtell@apache.org>
wrote:
>>>>> ...however we can't easily build a single artifact because the secure
RPC engine, as it interacts with the Hadoop auth framework, must use UserGroupInformation.
>>>>> 
>>>> 
>>>> OK.  So security story needs a bit of work.  Sounds like we have
>>>> enough votes though to require hadoop 1.0.0 at least in 0.96.
>>>> 
>>>> St.Ack
>> 
>> --
>> Arun C. Murthy
>> Hortonworks Inc.
>> http://hortonworks.com/
>> 
>> 
> 

Mime
View raw message