hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aditya Kumar <adityakumar...@yahoo.com>
Subject Re: problem starting HBase regional server
Date Mon, 12 Dec 2011 04:31:02 GMT
thank you for the response.

I do have zookeeper.jar?

 locate  zookeeper.jar
/usr/lib/hbase/lib/zookeeper.jar
/usr/lib/zookeeper/zookeeper.jar

what else I should see to resolve issue (1)


----- Original Message -----
From: Stack <stack@duboce.net>
To: dev@hbase.apache.org; Aditya Kumar <adityakumar345@yahoo.com>
Cc: 
Sent: Sunday, December 11, 2011 8:27 PM
Subject: Re: problem starting HBase regional server

On Sun, Dec 11, 2011 at 6:29 PM, Aditya Kumar <adityakumar345@yahoo.com> wrote:
> 1) I am having my hmaster running.
> when I start my regional server on the other host. I am getting the following Exception.
> can you please let me know what I am missing and also how to debug this?
>
> ==
> sudo /sbin/service hadoop-hbase-regionserver start
> starting regionserver, logging to /var/log/hbase/hbase-hbase-regionserver-host123.out
> Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/zookeeper/KeeperException
>         at java.lang.Class.getDeclaredMethods0(Native Method)
>         at java.lang.Class.privateGetDeclaredMethods(Class.java:2442)
>         at java.lang.Class.getMethod0(Class.java:2685)
>         at java.lang.Class.getMethod(Class.java:1620)
>         at sun.launcher.LauncherHelper.getMainMethod(LauncherHelper.java:484)
>         at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:476)
> Caused by: java.lang.ClassNotFoundException: org.apache.zookeeper.KeeperException
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:355)


You are missing the zookeeper jar it would seem.


> ==
>
>
> 2) My Hadoop is up and running.
> But when I try to connect to the Hbase from my BRoswer, I keep getting "connecting" in
the status Bar and no response.
> I tried: http://10.10.10.11:60010
>
> when I checked Hmaster it is running on 10.10.10.11. but the GUI does not come
>
>

Check master logs.  If it can't find zk jar, its not going to come up.



> 3) I have a Hadoop and Hbase installed in 5 hosts.
> if I want this to be given to 25 applications for accessing the DB, what are the configuration
changes that I should be taken into consideration
> like: ( in some applications max handles , threads) similarly what all I should be taken
into consideration.
>

Read the manual that is up on hbase.org.



> 4) when I try to connect to HBase shell
> it stops and does not proceed.
> =
> hbase(main):006:0* list
> TABLE
> 11/12/11 18:25:57 FATAL zookeeper.ZKConfig: The server in zoo.cfg cannot be set to localhost
in a fully-distributed setup because it won't be reachable. See "Getting Started" for more
information.
> =
>

What it says.  If listening on localhost, no one remote will be able to connect.

Again, check out aforementioned manual.

Good luck,

St.Ack


>
> Thanks again in advance.
>
> -Adi
>


Mime
View raw message