hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Akash Ashok <thehellma...@gmail.com>
Subject Re: Better Javadoc HTableDescriptor
Date Sat, 01 Oct 2011 12:02:58 GMT
While I was doing this I found out that there is a method in
HTableDescriptor called isMetaTable() which basically checks if the table is
a catalog table and the name kind of misleading. I am planning to rename
this method to isCatalogTable().

1. Is it ok to do this renaming considering that this is a client side API/
Admin API might lead to a lot of changes on client side for people already
using this method?

2. If yes, is it ok to do it under the same JIRA HBase-4486 or should
another another JIRA be file for this ?

3. If no, could this method be deprecated and another new method
isCatalogTable() be added ?

Cheers,
Akash A

On Mon, Sep 26, 2011 at 10:25 PM, Jean-Daniel Cryans <jdcryans@apache.org>wrote:

> Be my guest!
>
> J-D
>
> On Sat, Sep 24, 2011 at 9:16 AM, Akash <thehellmaker@gmail.com> wrote:
> > Hi,
> >     I was just lookin at the HTableDescriptor and realized it has very
> minimal javadoc. Considering this is an admin API I feel there should be
> better javadoc. If there's no Jira already open I would go ahead and file
> it. Thanks
> >
> > Sent from my iPhone
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message