hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Hsieh <...@cloudera.com>
Subject Re: maintaining stable HBase build
Date Tue, 27 Sep 2011 17:15:42 GMT
These are the flaky tests I've seen failing regularly from some time before
the around the 0.90.4 time to now. (we have a few backports that probably
shouldn't affect these tests) :

TestReplication.queueFailover
TestMasterFailover.testMasterFailoverWithMockedRIT
TestMasterFailover.testSimpleMasterFailover
TestRollingRestart.testBasicRollingRestart

I also tried backporting HBASE-4453 but it the replication queueFailover
test still fails occasionally.

These are being run on machines with several builds of other projects
running on them.

Jon

On Mon, Sep 26, 2011 at 3:19 PM, Andrew Purtell <apurtell@apache.org> wrote:

> A slow host (or busy running tests from other projects concurrently...) can
> cause failures in the replication tests.
>
>    - Andy
>
>
> ----- Original Message -----
> > From: Ted Yu <yuzhihong@gmail.com>
> > To: lars hofhansl <lhofhansl@yahoo.com>
> > Cc: "dev@hbase.apache.org" <dev@hbase.apache.org>
> > Sent: Monday, September 26, 2011 12:57 PM
> > Subject: Re: maintaining stable HBase build
> >
> > From TRUNK build 2259:
> >
> > Failed tests:   queueFailover(org.apache.
> > hadoop.hbase.replication.TestReplication): Waited too much time for
> > queueFailover replication
> >
> > I know Doug's change wouldn't have caused the above failure.
> >
> > FYI
>



-- 
// Jonathan Hsieh (shay)
// Software Engineer, Cloudera
// jon@cloudera.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message