hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: HBase Scan returns fewer columns after a few minutes of insertion
Date Tue, 30 Aug 2011 02:07:23 GMT
(Sending to user@ again and bccing dev@ for the last time, please take
notice and reply to user@)

Ok so it should be something about the code... what is batchSize set
to? I don't see it in that code snippet.

getMap gives a map of all the families with all the data, whereas
getFamily gives a map of all the qualifiers and their values for one
family. Both APIs are good, just solving a different problem.

J-D

On Mon, Aug 29, 2011 at 6:00 PM, Neerja Bhatnagar <neerjapub@gmail.com> wrote:
> Hi J-D,
>
> Thanks! I do scan 'tablename' on the shell, and I can see all 3 columns in
> the 1 column family for a row. I haven't set any TTL on the table or result
> scanner.
> Any other suggestions would be very welcome. I was getting the same response
> with result.getFamilyMap() and I moved to result.getMap() thinking I was
> using the wrong api.
>
> Cheers, Neerja
>
> On Mon, Aug 29, 2011 at 5:23 PM, Jean-Daniel Cryans <jdcryans@apache.org>wrote:
>
>> (sending to user@ and bbcing dev@ since this is a user question)
>>
>> That type of problem can be "fun" to debug, did you try with the shell
>> to query the data? Do you get a different result?
>>
>> BTW, any TTL set on that table?
>>
>> J-D
>>

Mime
View raw message