hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: running unit tests
Date Sun, 05 Jun 2011 23:00:06 GMT
Nothing is required, look at the log of the first test and see what
it's complaining on.

J-D

On Sun, Jun 5, 2011 at 3:58 PM, Rakesh Aggarwal
<rakesh.aggarwal@gmail.com> wrote:
> Hi! I am new to HBase development and tried running unit tests after
> checking out HBase trunk. I am see'ing the following failures (pasted
> below).
>
> Is there any setup required before running the unit test? For example, do I
> need to start zoo-keeper cluster manually before running the tests?
>
> Thanks
>
> -Rakesh
>
> =======================================================================
> rakesh@ubuntu:~/Hbasewrk/hbase-core-trunk$ mvn test
> [INFO] Scanning for projects...
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building HBase
> [INFO]    task-segment: [test]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] [antrun:run {execution: generate}]
> [INFO] Executing tasks
> ...[snipped]
> Running org.apache.hadoop.hbase.coprocessor.TestCoprocessorInterface
> Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 1.849 sec
> <<< FAILURE!
> Running org.apache.hadoop.hbase.TestZooKeeper
> Tests run: 7, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 453.877 sec
> ....[snipped]
> Tests run: 11, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.56 sec
> Running org.apache.hadoop.hbase.zookeeper.TestHQuorumPeer
> Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.182 sec
> Running org.apache.hadoop.hbase.regionserver.TestSplitTransactionOnCluster
> killed.
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error while executing forked tests.; nested exception is
> org.apache.maven.surefire.booter.shade.org.codehaus.plexus.util.cli.CommandLineException:
> Error while executing external command, process killed.
>
> Process timeout out after 900 seconds
>

Mime
View raw message