hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Todd Lipcon <t...@cloudera.com>
Subject Re: version check for hbase-default.xml
Date Thu, 17 Feb 2011 23:17:49 GMT
Where are you getting the hbase-defaults.xml file that you're packaging into
your jar?

You need to take it out of the hbase jar that ships with 0.90.1 and package
that one -- my guess is you've packaged one from an older version.

-Todd

On Thu, Feb 17, 2011 at 3:01 PM, Ted Yu <yuzhihong@gmail.com> wrote:

> We re-package hbase jar into the jar containing our classes.
>
> [sjc1-hadoop0.sjc1:hadoop 36789]jar tvf
> /usr/local/hadoop/sims/lib/flow-m2m_hbase_regr-38.jar | grep MetaSca
>  7030 Fri Feb 11 11:50:28 GMT+00:00 2011
> org/apache/hadoop/hbase/client/MetaScanner.class
>  2027 Fri Feb 11 11:50:28 GMT+00:00 2011
> org/apache/hadoop/hbase/client/MetaScanner$1.class
> [sjc1-hadoop0.sjc1:hadoop 36791]jar tvf
> /usr/local/hadoop/sims/lib/flow-m2m_hbase_regr-38.jar | grep default | grep
> hbase
>  23610 Fri Feb 11 11:50:22 GMT+00:00 2011 hbase-default.xml
>
> If the above jar structure is incorrect, please comment.
>
> Using 0.90.1 jar as client, I saw:
>
> INFO [2011-02-17 06:52:23] (ExecUtil.java:261) -
> java.lang.RuntimeException: hbase-default.xml file seems to be for and
> old version of HBase (null), this version is 0.90.1
> INFO [2011-02-17 06:52:23] (ExecUtil.java:261) -       at
>
> org.apache.hadoop.hbase.HBaseConfiguration.checkDefaultsVersion(HBaseConfiguration.java:66)
> INFO [2011-02-17 06:52:23] (ExecUtil.java:261) -       at
>
> org.apache.hadoop.hbase.HBaseConfiguration.addHbaseResources(HBaseConfiguration.java:76)
> INFO [2011-02-17 06:52:23] (ExecUtil.java:261) -       at
>
> org.apache.hadoop.hbase.HBaseConfiguration.<init>(HBaseConfiguration.java:44)
> INFO [2011-02-17 06:52:23] (ExecUtil.java:261) -       at
>
> org.apache.hadoop.hbase.HBaseConfiguration.<init>(HBaseConfiguration.java:56)
>
> I looked at Configuration.java which has quiet mode setter. But the above
> exception happened in ctor.
>
> Please advise how I can troubleshoot this.
>



-- 
Todd Lipcon
Software Engineer, Cloudera

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message