hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject table not shown on master UI but creating same table fails
Date Fri, 19 Nov 2010 17:56:32 GMT
Hi,
We use hbase 0.20.6
We're facing weird state for a particular table:

2010-11-19 09:25:08,350 Thread-20 ERROR [StripedHBaseTable] Could not
create packageindex
org.apache.hadoop.hbase.TableExistsException:
org.apache.hadoop.hbase.TableExistsException: packageindex
	at org.apache.hadoop.hbase.master.HMaster.createTable(HMaster.java:799)
	at org.apache.hadoop.hbase.master.HMaster.createTable(HMaster.java:763)
	at sun.reflect.GeneratedMethodAccessor25.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.apache.hadoop.hbase.ipc.HBaseRPC$Server.call(HBaseRPC.java:657)
	at org.apache.hadoop.hbase.ipc.HBaseServer$Handler.run(HBaseServer.java:998)

	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
	at org.apache.hadoop.hbase.RemoteExceptionHandler.decodeRemoteException(RemoteExceptionHandler.java:94)
	at org.apache.hadoop.hbase.client.HBaseAdmin.createTableAsync(HBaseAdmin.java:283)
	at org.apache.hadoop.hbase.client.HBaseAdmin.createTable(HBaseAdmin.java:240)
	at org.apache.hadoop.hbase.client.HBaseAdmin.createTable(HBaseAdmin.java:206)
...
2010-11-19 09:25:08,352 Thread-20 INFO
[HBasePackageIndexTableMapperNew] Creating table packageindex - Done
2010-11-19 09:25:08,374 Thread-20 INFO  [CodecPool] Got brand-new decompressor
2010-11-19 09:25:08,396 Thread-20 INFO
[HBasePackageIndexTableMapperNew] OnClose called
2010-11-19 09:25:08,397 Thread-20 WARN  [LocalJobRunner] job_local_0001
org.apache.hadoop.hbase.TableNotFoundException: packageindex
	at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegionInMeta(HConnectionManager.java:698)
	at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:634)
	at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:601)
	at org.apache.hadoop.hbase.client.HTable.<init>(HTable.java:134)
	at org.apache.hadoop.hbase.client.HTable.<init>(HTable.java:112)

Can someone suggest what I should do so that I can create this table again ?

Thanks

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message