hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <st...@duboce.net>
Subject Re: NoSuchColumnFamily Exception
Date Wed, 13 Oct 2010 22:13:41 GMT
As per that thread, disabling and enabling tables is problematic in
0.20.  Do you need this facility evaluating hbase?  Did you do as that
thread suggests ensuring disable worked before moving on to disable
(by scanning .META. looking for presence of enable flag on each of
your two regions)?

Yours,
St.Ack

On Wed, Oct 13, 2010 at 1:42 AM, Gagandeep Singh
<gagandeep.singh@paxcel.net> wrote:
> Recently I moved to HBase 0.20.6 version  and I am facing somewhat strange
> problems.
>
> I have 3 VMs cluster on 32 bit machines with HDFS 20.2. One is master and
> other two are region servers. When I create 2 tables, they are created on
> two different regions. I inserted 5 records manually from shell I find that
> my table got split into two and is present on both the region servers. I
> then tried to run my java application which first truncates the tables by
> disabling, dropping and recreating tables but then I got following
> exception.
>
> org.apache.hadoop.hbase.regionserver.NoSuchColumnFamilyException:
> org.apache.hadoop.hbase.regionserver.NoSuchColumnFamilyException: Column
> family files does not exist in region
>    at
> org.apache.hadoop.hbase.regionserver.HRegion.checkFamily(HRegion.java:2587)
>    at org.apache.hadoop.hbase.regionserver.HRegion.put(HRegion.java:1390)
>    at org.apache.hadoop.hbase.regionserver.HRegion.put(HRegion.java:1363)
>    at
> org.apache.hadoop.hbase.regionserver.HRegionServer.put(HRegionServer.java:1783)
>
> Not sure what is wrong. I searched on mail archives and found  this link -
> http://www.listware.net/201004/hadoop-hbase-user/24572-regions-assigned-multiple-times-after-disabling-table.html
> After reformatting my NameNode I tried to do everything from scratch but I
> also got stuck in the problem mentioned in the listware link above.
>
> Thanks,
> Gagan
>

Mime
View raw message