hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Koch <tho...@koch.ro>
Subject HBase and OpenJDK
Date Fri, 23 Apr 2010 14:50:01 GMT

I'm working on the Debian package for HBase. On Debian, the default JVM is 
OpenJDK, since it's free and the SUN JVM isn't much loved by the debian-java 
Now when running HBase on OpenJDK 1.6.0_18 the master frontend shows the 
"Your current JVM version 1.6.0_18 is known to be unstable with HBase. Please 
see the HBase wiki  for details."

Has anybody already made experiences with running Hadoop/HBase on OpenJDK? 
Does the above warning also apply for this JVM?
For a broader addoption of Hadoop/HBase I'd recommend to do also testing on 
OpenJDK since I wouldn't be sure if the proprietary SUN JVM will remain much 
longer in Debian. (Don't know about Red Hat.)

Best regards,

Thomas Koch, http://www.koch.ro

View raw message