hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lars George <lars.geo...@gmail.com>
Subject Re: Running local after build broken?
Date Wed, 17 Feb 2010 21:33:07 GMT
No, this is a standard start for local testing, this always worked. Simply do

svn co <hbase-trunk>
cd <hbase-trunk>
ant
build/bin/start-hbase.sh

and you had a local version running.

On Wed, Feb 17, 2010 at 10:30 PM, Kay Kay <kaykay.unique@gmail.com> wrote:
> Does it help to bypass distMode altogether and directly use distributed mode
> (which I assume is what you are looking at )  , manually launching the
> servers using hbase-daemon.sh (master/ zk)  ?
>
>
>
>
> On 2/17/10 12:52 PM, Lars George wrote:
>>
>> I see the libs in build/ivy/lib/common, is that something else?
>>
>> The error happens here:
>>
>> ...
>> if [ $distMode == 'false' ]
>> ...
>>
>> Shouldn't that be [[...]]?
>>
>> Why am I the only one that has this issue? This is MacOS 10.6 and a
>> normal hbase-0.21.0 trunk build.
>>
>> Here the classpath dumped in bin/hbase:
>>
>> larsmacbookpro:hbase-trunk-ro larsgeorge$ build/bin/start-hbase.sh
>> build/bin/start-hbase.sh: line 44: [: too many arguments
>> sed: 1: "s/^//Development/eclips ...": bad flag in substitute command: 'D'
>> Classpath:: ssh: Could not resolve hostname Classpath:: nodename nor
>> servname provided, or not known
>> localhost: starting zookeeper, logging to
>>
>> /Development/eclipse/workspace/hbase-trunk-ro/build/bin/../logs/hbase-larsgeorge-zookeeper-larsmacbookpro.fritz.box.out
>> localhost: Classpath:
>>
>> /Development/eclipse/workspace/hbase-trunk-ro/build/bin/../conf:/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home//lib/tools.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/..:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../hbase-0.21.0-dev.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/ant-1.6.5.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/asm-3.0.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/avro-1.2.0.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/commons-cli-1.2.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/commons-codec-1.3.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/commons-el-1.0.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/commons-httpclient-3.0.1.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/commons-lang-2.4.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/commons-logging-1.1.1.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/commons-net-1.4.1.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/core-3.1.1.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/hadoop-core-0.21.0-SNAPSHOT.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/hadoop-hdfs-0.21.0-SNAPSHOT.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/hadoop-mapred-0.21.0-SNAPSHOT.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/hsqldb-1.8.0.10.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/jackson-core-asl-1.0.1.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/jackson-mapper-asl-1.0.1.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/jasper-compiler-5.5.12.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/jasper-runtime-5.5.12.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/jets3t-0.7.1.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/jetty-6.1.14.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/jetty-util-6.1.14.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/jline-0.9.94.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/jruby-complete-1.3.1.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/jsp-2.1-6.1.14.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/jsp-api-2.1-6.1.14.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/junit-4.5.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/kfs-0.3.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/libthrift-0.2.0.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/log4j-1.2.15.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/lucene-core-2.2.0.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/oro-2.0.8.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/paranamer-1.5.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/paranamer-ant-1.5.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/paranamer-generator-1.5.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/qdox-1.9.1.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/servlet-api-2.5-6.1.14.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/slf4j-api-1.5.8.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/slf4j-simple-1.5.8.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/xmlenc-0.52.jar:/Development/eclipse/workspace/hbase-trunk-ro/build/bin/../lib/zookeeper-3.2.2.jar
>>
>> Weird.
>>
>>
>> On Wed, Feb 17, 2010 at 8:25 PM, Kay Kay<kaykay.unique@gmail.com>  wrote:
>>
>>>
>>> On 2/17/10 10:56 AM, Lars George wrote:
>>>
>>>>
>>>> build/bin/start-hbase.sh: line 44: [: ==: unary operator expected
>>>>
>>>
>>> Not sure - if this is related - but you could check what is wrong with
>>> this
>>> .
>>>
>>> Meanwhile - what does the CLASSPATH in the start-hbase.sh script say
>>>  (w.r.t
>>> jars ). The right jars should be available at - build/ivy/common/*.jar
>>> and
>>> build/contrib/**/ivy/common/*.jar .
>>>
>>> Do the CLASSPATH identified by the bash script match the actuals.
>>>
>>>
>>>
>
>
>

Mime
View raw message