hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benoit Sigoure (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-2178) Hooks for replication
Date Tue, 02 Feb 2010 06:34:19 GMT

    [ https://issues.apache.org/jira/browse/HBASE-2178?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12828497#action_12828497

Benoit Sigoure commented on HBASE-2178:

I'm not sure I understand why you're making 4 fields public in the {{ZooKeeperWrapper}} class,
the only one you're accessing in your patch for HBASE-2129 is {{parentZNode}}.  And for this
one I think an accessor would be better.

In {{scanAddressDirectory}}, I would declare the {{List<HServerAddress> list}} after
the check on {{nodes == null}} that does an early return.  This improves readability and this
way you can also invoke the constructor with the exact size of the {{ArrayList}} in advance:
double win!

In {{listZnodes}}, I don't know why you wrapped the arguments around.  They fit nicely on
one line.

In {{writeZNode}}, there's some code in the try-block that's not indented.

Just out of curiosity, why are you moving the {{import java.foo}} after the {{import org.apache.bar}}?

Also I'm not sure I understand why you removed the call to {{this.conf.setBoolean("dfs.support.append",
true);}} in {{setUp}} in {{TestHLog}}.

> Hooks for replication
> ---------------------
>                 Key: HBASE-2178
>                 URL: https://issues.apache.org/jira/browse/HBASE-2178
>             Project: Hadoop HBase
>          Issue Type: Improvement
>            Reporter: Jean-Daniel Cryans
>            Assignee: Jean-Daniel Cryans
>             Fix For: 0.21.0
>         Attachments: HBASE-2178-2.patch, HBASE-2178.patch
> This issue is about getting all the hooks for mdc replication in core HBase.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message