hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kay Kay (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HBASE-2193) Better readability of - hbase.regionserver.lease.period
Date Mon, 08 Feb 2010 21:53:27 GMT

     [ https://issues.apache.org/jira/browse/HBASE-2193?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kay Kay updated HBASE-2193:
---------------------------

    Status: Patch Available  (was: Open)

> Better readability of - hbase.regionserver.lease.period 
> --------------------------------------------------------
>
>                 Key: HBASE-2193
>                 URL: https://issues.apache.org/jira/browse/HBASE-2193
>             Project: Hadoop HBase
>          Issue Type: Improvement
>            Reporter: Kay Kay
>         Attachments: HBASE-2193.patch
>
>
> Property - "hbase.regionserver.lease.period" hardcode would be ideally moved to HConstants.

> Also - default value seems to be listed all over the place, (thankfully consistent though).
That would be nice to be in HConstants too .. 
> $ find . -name \*.java | xargs grep -nr hbase.regionserver.lease.period
> ./src/contrib/mdc_replication/src/java/org/apache/hadoop/hbase/replication/ReplicationConnectionManager.java:59:
   this.rpcTimeout = conf.getLong("hbase.regionserver.lease.period", 60000);
> ./src/java/org/apache/hadoop/hbase/client/HConnectionManager.java:298:      this.rpcTimeout
= conf.getLong("hbase.regionserver.lease.period", 60000);
> ./src/java/org/apache/hadoop/hbase/client/HTable.java:121:      conf.getInt("hbase.regionserver.lease.period",
60 * 1000);
> ./src/java/org/apache/hadoop/hbase/regionserver/HRegionServer.java:271:    this.rpcTimeout
= conf.getLong("hbase.regionserver.lease.period", 60000);
> ./src/java/org/apache/hadoop/hbase/regionserver/HRegionServer.java:335:        conf.getInt("hbase.regionserver.lease.period",
60 * 1000),
> ./src/test/org/apache/hadoop/hbase/regionserver/TestHRegion.java:1890:    conf.setInt("hbase.regionserver.lease.period",
10 * 1000);
> More of a nit, but provides better readability across. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message