hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-1728) Column family scoping and cluster identification
Date Tue, 16 Feb 2010 19:49:27 GMT

    [ https://issues.apache.org/jira/browse/HBASE-1728?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12834413#action_12834413

stack commented on HBASE-1728:

.bq Ryan's point is valid (to be able to change HCD without disable) but resolving that is
outside of the scope of this jira (he agrees on that). This should not be a blocker.

I agree.  Master rewrite should get this.  All of HCD and tabledefinition will be up in zk.

.bq The KV should not carry the scoping information since it's only needed in HLog where we
already have access to the HTD.


.bq Also note the danger in having a code-oriented 'default' scope that is being written into
every single record. Not that the default would ever change, but we should observe the lessons
of https://issues.apache.org/jira/browse/HBASE-2213 in recording defaults in every HCD.

This should be fixed in master rewrite where we record only deviations from default.

Regards the patch:

+    String clusterIdName =
+            conf.get("zookeeper.znode.clusterId", "clusterId");

Does this mean that only one cluster can be associated with one zk instance?  Or is the notion
that if mutliple clusters are sharing the one zk ensemble, then they will be homed (gaol'd)
at different areas up in zk ( I suppose that makes sense -- huh -- they'd have to be)

Aside, 'isMaster' is a bad name for a datamember.  Should be 'master' at least by javabeans

What does method name deviate from data member name in below:

+  public byte getRepId() {
+    return this.clusterId;

Align them?  Make method name getClusterId?

+  public static final String SCOPE = "SCOPE"; ... is too generic.  Make it REPLICATION_SCOPE
or REP_SCOPE or something.

The change to HLogKey means we can't read old logs.  Thats probably fine, right?  Migration
requires that there be no hlogs in filesystem?

+1 on commit fixing above beforehand.

> Column family scoping and cluster identification
> ------------------------------------------------
>                 Key: HBASE-1728
>                 URL: https://issues.apache.org/jira/browse/HBASE-1728
>             Project: Hadoop HBase
>          Issue Type: Sub-task
>            Reporter: Andrew Purtell
>            Assignee: Jean-Daniel Cryans
>             Fix For: 0.21.0
>         Attachments: HBASE-1728.patch, HCD-family-scoping.patch, HLogKey-scoping.patch
> Support column family scoping via a new HCD attribute. Provide initial set of scoping
constants and javadoc setting expectations for a simple default binary scoping policy: replicate,
or do not. Make the underlying type Integer so more complex edit routing policies are possible.
Also identify every HLogKey with the original cluster's ID.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message