hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stack <st...@duboce.net>
Subject Re: Vote on getting org.apache.hadoop.hbase.mapred back in 0.21
Date Fri, 15 Jan 2010 22:48:26 GMT
I'm fine w/ us requiring mapreduce as opposed to mapred going into 0.21
except for the part where we'll break our cascading hookup.  So, +1 (Let me
ping Chris to see if this mapred vs mapreduce story for cascading is going
to change any time soon).
St.Ack

On Fri, Jan 15, 2010 at 2:02 PM, Jean-Daniel Cryans <jdcryans@apache.org>wrote:

> Hi devs,
>
> The removing of the old HBase mapred API while Hadoop 0.21 is still
> keeping it causes the situation where we are forcing users to migrate
> while they may not have to. Also, other projects like cascading
> continue to rely on the old Hadoop mapred API so their HBase module
> will break. This is very problematic.
>
> What I propose is that we get the org.apache.hadoop.hbase.mapred
> package back in 0.21. To do that, we need to refactor all the
> dependencies on the old client API to use the new one. The impact on
> users upgrading from 0.20 to 0.21 with MR jobs using the old package
> will be the same, they will have to change all the client calls in
> their code.
>
> This is ok with everyone?
>
> If the vote passes, I will do the work.
>
> J-D
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message