hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Francke (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HBASE-1360) move up to Thrift 0.1
Date Sun, 17 Jan 2010 02:01:55 GMT

     [ https://issues.apache.org/jira/browse/HBASE-1360?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Lars Francke updated HBASE-1360:
--------------------------------

    Attachment: hbase-1360.patch

As a first step this could be done now.

Unfortunately Thrift 0.2 introduces two new .jar dependencies. SLF4J:
* slf4j-api-1.5.8.jar
* slf4j-simple-1.5.8.jar

As two different Thrift versions can cause problems and the current Thrift API will stay at
least for 0.21 we need those dependencies and the new Thrift 0.2 jar in the core dependencies.
All three can be removed once thrift moves out of the core and only to contrib.

SLF4J is in the Maven repositories so Ivy should be able to pull those. I've added a patch
that adds SLF4J though someone familiar with Ivy should probably check that it's correct.
Should I attach the new libthrift-0.2.0.jar to this ticket as well? It can be generated easily
from the thrift release http://incubator.apache.org/thrift/download/

> move up to Thrift 0.1
> ---------------------
>
>                 Key: HBASE-1360
>                 URL: https://issues.apache.org/jira/browse/HBASE-1360
>             Project: Hadoop HBase
>          Issue Type: Improvement
>          Components: thrift
>            Reporter: Andrew Purtell
>         Attachments: hbase-1360.patch
>
>
> Move HBase thrift bits up to Thrift 0.1 when it is released.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message