hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Rawson <ryano...@gmail.com>
Subject Re: Hbase on 64-bit Windows 7: "hostname not provided"
Date Sat, 26 Dec 2009 07:40:23 GMT
I have a patch that runs zookeeper within the master JVM, but I dont
think it would entirely solve this for you, because clients use
'localhost' the value we ship with in hbase-default.xml to locate the
ZK process. You'd just shift the problem a bit.

How can we make life easier for you cygwin users? Why is there no
localhost for you?

On Fri, Dec 25, 2009 at 1:18 PM, Dave Latham <latham@davelink.net> wrote:
> I've seen a similar message in cygwin after upgrading to hbase 0.20.  I
> believe that start-hbase.sh uses ZKServerTool to get the zookeeper hosts
> from the conf file. However, on windows or cygwin, it returns hosts with a
> newline as part of the name.  As a result, start-hbase tries to ssh to
> "hostname\n" or so, and windows fails.  I have a colleague who tried it on
> Windows 7 (64-bit) and I think it worked after he disabled IPv6.  Perhaps
> with IPv6, windows is stricter about the name and can't handle the white
> space.  Even with Windows XP, though, since hbase 0.20 I've had to keep a
> known_hosts file with an entry containing a newline to match what
> start-hbase gets from ZKServerTool.
>
> Dave
>
> On Fri, Dec 25, 2009 at 10:25 AM, John Roberts <johnroberts239@yahoo.com>wrote:
>
>> Has anyone successfully run hbase on 64-bit Windows 7?  I was able to get
>> hbase working on Windows XP following these instructions:
>>
>> http://highestpoint.biz/2009/10/installing-hbase-on-windows/
>>
>> I followed the exact same instructions for a PC running 64-bit Windows 7
>> but when I run start-hbase.sh I get this error:
>>
>> ": hostname nor servname provided, or not known"
>>
>> On my Windows XP PC I get prompted twice for the password but on my Windows
>> 7 PC I only get prompted once and after that I get errors trying to run
>> commands in hbase shell.
>>
>> Does anyone know why I get the error about hostname not provided?
>>
>> Thanks.
>>
>> John
>>
>>
>>
>

Mime
View raw message