hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Gray (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HBASE-1790) filters are not working correctly
Date Wed, 02 Sep 2009 22:12:32 GMT

     [ https://issues.apache.org/jira/browse/HBASE-1790?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Gray updated HBASE-1790:
---------------------------------

    Attachment: HBASE-1790-v6.patch

As described.  Addresses everything but HBC/HOW issue.

> filters are not working correctly
> ---------------------------------
>
>                 Key: HBASE-1790
>                 URL: https://issues.apache.org/jira/browse/HBASE-1790
>             Project: Hadoop HBase
>          Issue Type: Bug
>          Components: filters
>    Affects Versions: 0.20.0, 0.21.0
>            Reporter: Matus Zamborsky
>            Assignee: Jonathan Gray
>             Fix For: 0.20.0, 0.21.0
>
>         Attachments: 1790-3.patch, HBASE-1790-v2.patch, HBASE-1790-v4.patch, HBASE-1790-v5.patch,
HBASE-1790-v6.patch, hbase-1790.patch, testfilter.patch
>
>
> Filters used in Scanning the table are not working correctly. For example a table with
three rows:
> 1. rowkey = adminbackslash-nb0, desc:temp = "temp"
> 2. rowkey = adminbackslash-nb1, desc:temp = "temp"
> 3. rowkey = adminkleptoman, desc:temp = "temp"
> If I scan all rows in the table without filter I get all the rows as expected. But applying
a simple prefixfilter with parameter "adminbackslash" will return only first row. I searched
it down to HRegion::nextInternal method, which will not output one passed row before denied
row(by filter). 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message