hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HBASE-1784) Missing rows after medium intensity insert
Date Thu, 27 Aug 2009 16:36:59 GMT

     [ https://issues.apache.org/jira/browse/HBASE-1784?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

stack updated HBASE-1784:
-------------------------

    Fix Version/s: 0.20.0

Bringing into 0.20.0

> Missing rows after medium intensity insert
> ------------------------------------------
>
>                 Key: HBASE-1784
>                 URL: https://issues.apache.org/jira/browse/HBASE-1784
>             Project: Hadoop HBase
>          Issue Type: Bug
>    Affects Versions: 0.20.0
>            Reporter: Jean-Daniel Cryans
>            Priority: Blocker
>             Fix For: 0.20.0
>
>         Attachments: DataLoad.java, double-assignment, HBASE-1784.log, META.log, processSplitRegion-check-regionIsOpening.patch
>
>
> This bug was uncovered by Mathias in his mail "Issue on data load with 0.20.0-rc2". Basically,
somehow, after a medium intensity insert a lot of rows goes missing. Easy way to reproduce
: PE. Doing a PE scan or randomRead afterwards won't uncover anything since it doesn't bother
about null rows. Simply do a count in the shell, easy to test (I changed my scanner caching
in the shell to do it faster).
> I tested some light insertions with force flush/compact/split in the shell and it doesn't
break.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message