hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stack <st...@duboce.net>
Subject Re: new API method HTable.incrementColumnValue hangs
Date Mon, 15 Jun 2009 16:38:44 GMT
On Mon, Jun 15, 2009 at 5:55 AM, Irfan Mohammed <irfan.ma@gmail.com> wrote:

> using the hbase from the trunk on ubuntu 9.04
>
> irfan@damascus:~$ hbase shell
> HBase Shell; enter 'help<RETURN>' for list of supported commands.
> Version: 0.20.0-dev, r784503, Sun Jun 14 15:36:01 EDT 2009
>
> Whenever I use the new API call [HTable.incrementColumnValue], the process
> hangs. If I kill the process and later try to access the table records
> anywhere including "hbase shell" etc., even that process hangs.
>
> 1. "stop-hbase.sh" hangs as well and I have to kill the hbase processes



Please make a thread dump -- "% kill -QUIT PID" -- and pastebin what you
see.  I'd be interested in seeing why hbase won't go down.


>
> 2. restart the hbase using "start-hbase.sh"
> 3. hbase shell> count 't1' ---> throws an error that the table if offline
> 4. so had to enable 't1' and then work with the table.
>

....


Going by above, maybe something else is up in your hbase cluster?

Maybe, ensure all is well before you run your code by doing a few operations
with the shell on initial startup?

Your code doesn't have obvious errors on a quick glance.

Ensure your cluster is healthy before you run your own code, I'd suggest.

St.Ack

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message