hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-1385) Revamp TableInputFormat, needs updating to match hadoop 0.20.x AND remove bit where we can make < maps than regions
Date Sun, 28 Jun 2009 00:20:47 GMT

    [ https://issues.apache.org/jira/browse/HBASE-1385?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12724910#action_12724910
] 

stack commented on HBASE-1385:
------------------------------

If we change TMap to TMapper, should we change name of utility methods from initTableMapJob
to initTableMapperJob?

The \n in below is probably in wrong place now that numMapTasks have been removed:

{code}
r <numReduceTasks>\n  -indexConf <iconfFile> " +
{code}

IRW is all ^Ms as are other classes.  Not important.  Probably not you.

Is the split algorithm the same as old days?  I suppose it is since not in this patch.   


Only objection I had to 1548 was this:

{code}
+        scan.setMaxVersions();
{code}

Some lines are > 80 characters.  Convention is to try and keep them < 80 if makes sense.

If a start/stop time is set, then max versions is set which I'd think most would find odd.
 I'd remove this line for now.  Someone can come along later and make an issue to set versions
via the Job object.

Otherwise patch is high-quality.  Thanks for working on this Lars (new hadoop API seems to
clean up loads of stuff).



> Revamp TableInputFormat, needs updating to match hadoop 0.20.x AND remove bit where we
can make < maps than regions
> -------------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-1385
>                 URL: https://issues.apache.org/jira/browse/HBASE-1385
>             Project: Hadoop HBase
>          Issue Type: Bug
>            Reporter: stack
>             Fix For: 0.21.0
>
>         Attachments: 1385-v2.patch, 1385.patch, mr.patch
>
>
> Update TIF to match new MR.
> Remove the bit of logic where we will use number of configured maps as splits count rather
than regions.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message