hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Holstad (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-1578) Change the name of the in-memory updates from 'memcache' to 'memtable' or....
Date Wed, 24 Jun 2009 16:13:07 GMT

    [ https://issues.apache.org/jira/browse/HBASE-1578?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12723612#action_12723612

Erik Holstad commented on HBASE-1578:

I thought Ryan was all about the buffers like memBuffer :). +1 on changing the name.

> Change the name of the in-memory updates from 'memcache' to 'memtable' or....
> -----------------------------------------------------------------------------
>                 Key: HBASE-1578
>                 URL: https://issues.apache.org/jira/browse/HBASE-1578
>             Project: Hadoop HBase
>          Issue Type: Improvement
>            Reporter: stack
>             Fix For: 0.20.0
> Our map of sorted edits kept per Store is currently called memcache.  Memcache is name
of a well-known app that does something else.  Also, our 'memcache' is not a cache.  In BT
its called 'memtable'.  Lets rename it.  It'll make it easier explaining hbase.  What'll we
call it?  'updates', 'inmemory-store-edits'....

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message