hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-1304) New client server implementation of how gets and puts are handled.
Date Tue, 28 Apr 2009 17:46:30 GMT

    [ https://issues.apache.org/jira/browse/HBASE-1304?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12703768#action_12703768
] 

stack commented on HBASE-1304:
------------------------------

+ I think multifamily as an attribute a little redundant
+ MAX_FAMILY_LENGTH belongs better in KV
+ Ok on new names (was thinking we should start up a new hosting HTable class so you could
keep method names like commit)
+ I think figuring the high-level class model, what the user sees, is probably the first order
of business -- or at least belongs up there as a priority.  The model needs to be tests for
puts, deletes, gets and scans; everything.
+ Could GetTop be a Get against a family?  Versions would in this case return that many of
the family entries (the 'top' columns).
+ RowUpdates needs to passing KeyValues.
+ Regards Family object verses repeating family name in an array of arrays, lets say average
get goes against one or two families, and that family name is generally short -- url, ts,
page.  Given that Family object with its internal List is how much?  50/80 bytes?  Then on
average I'd think current setup cheaper?
+ Family seems like a bad name for this class.  Column would be better?
+ I didn't look at the isDeleted too deeply but seemed like duplication here with other parts
of the patch.  I know what you mean about carrying state  -- can make it hard not duplicating
code snippets -- but we should make an effort; when I see all this state-carrying code, I
see lots of opportunity for bugs.... Needs good testing.

I'm not seeing a focus on zero-copy in this patch; passing KV out to client.  Am I missing
it or is it just not there yet?

I'm thinking that what with working out model, figuring out optimal client/server message
passing, changing deletes to work in the new way, effectively rewriting regionserver again
-- took me about a month to do it recently -- to implement the new server-side versions of
new client-side objects, I'm thinking that 0.20.0 is 4-8 weeks out if we include this stuff.
 I think that too long to wait.

> New client server implementation of how gets and puts are handled. 
> -------------------------------------------------------------------
>
>                 Key: HBASE-1304
>                 URL: https://issues.apache.org/jira/browse/HBASE-1304
>             Project: Hadoop HBase
>          Issue Type: Improvement
>    Affects Versions: 0.20.0
>            Reporter: Erik Holstad
>            Assignee: Erik Holstad
>            Priority: Blocker
>         Attachments: hbase-1304-v1.patch
>
>
> Creating an issue where the implementation of the new client and server will go. Leaving
HBASE-1249 as a discussion forum and will put code and patches here.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message