hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stack <st...@duboce.net>
Subject Re: [jira] Commented: (HBASE-1234) Change HBase StoreKey format
Date Sat, 07 Mar 2009 21:40:48 GMT
Tell me more about what you are thinking Erik.  How you mean open?

I changed it because it seemed to make better sense when I started in on the
KeyValue class; most of the accesses are to get the rows to do compares so
my thought was not to not mix in any column concerns.  Let me go back though
because now KeyValue has been mostly flushed out,
let me see if the original format might not make more sense after all.


On Sat, Mar 7, 2009 at 12:58 PM, Erik Holstad <erikholstad@gmail.com> wrote:

> Hey Stack!
> Been looking at the code and will put up my stuff on git as soon as I can
> check them
> out properly. Just one thing that I saw, the format for the key is now
> (rowLen)(row)(familyLen)(family)
> I think it would be better to have it
> (rowLen)(familyLen)(row)(family)
> just to keep it open of how to treat the array at the client side in the
> future.
> Erik

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message