hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Holstad (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (HBASE-1189) Changing the map type used internally for HbaseMapWritable.
Date Thu, 19 Feb 2009 19:08:02 GMT

    [ https://issues.apache.org/jira/browse/HBASE-1189?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12675090#action_12675090
] 

erikholstad@gmail.com edited comment on HBASE-1189 at 2/19/09 11:07 AM:
---------------------------------------------------------------

New patch with some small fixes, changed the name of the static loader to be 
better and shorter.
I think that the variables in the class needs to be public, tried to make them private
though it would make more sense but the complier didn't like that.
Not sure what will happened if you have the internal methods set to static too, but I would
assume that they would take up memory. 
Yes was thinking that you edit the file if you want to add more classes, just like you did
in 
the past, not really sure how you would do it otherwise since it is static.

      was (Author: erikholstad@gmail.com):
    New patch with some small fixes, changed the name of the static loader to be 
better and shorter.
  
> Changing the map type used internally  for HbaseMapWritable. 
> -------------------------------------------------------------
>
>                 Key: HBASE-1189
>                 URL: https://issues.apache.org/jira/browse/HBASE-1189
>             Project: Hadoop HBase
>          Issue Type: New Feature
>          Components: io
>    Affects Versions: 0.20.0
>            Reporter: Erik Holstad
>            Assignee: Erik Holstad
>            Priority: Minor
>         Attachments: HBASE-1189-v1.patch, HBASE-1189-v2.patch, HbaseMapWritable.java,
StaticLoader.java
>
>
> For the CellCache the need for a HbaseMapWritable that has a different kind of map used
internally
> has showed up. The problem is that the instantiation of the map is done static so you
have no control 
> over it and if extending HMW you get both the memory usage for the parent as well as
the child.
> After trying out different ideas on how to solve this, it seems like the easiest way
would be to have a setMapType
> method and just set it to null in the code. If the old code would be kept you would need
to instantiate 2
> different maps. The problem with setting it to null is that all the old code needs to
be changed to fit the new model,
> and also be used in the future.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message