hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clint Morgan (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-1054) Index descriptions are not copied in HTableDescriptor copy constructor
Date Wed, 10 Dec 2008 01:56:44 GMT

    [ https://issues.apache.org/jira/browse/HBASE-1054?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12655077#action_12655077
] 

Clint Morgan commented on HBASE-1054:
-------------------------------------

The multiple region issue was due to a messed up deployment by me (multiple hbase data dirs
overlayed on top of each other). Sorry for the noise.

 I would still like the patch to go through as it fixes this NPE I was getting too.

> Index descriptions are not copied in HTableDescriptor copy constructor
> ----------------------------------------------------------------------
>
>                 Key: HBASE-1054
>                 URL: https://issues.apache.org/jira/browse/HBASE-1054
>             Project: Hadoop HBase
>          Issue Type: Bug
>            Reporter: Clint Morgan
>            Assignee: Clint Morgan
>         Attachments: hbase-1054.patch
>
>
> I had some tables refuse to find their indexes even though they were defined and had
been updated. Scanning .META. I see that some regions from the table don't have the indexes...
> Oddly, during  the .META. scan, I would see that I had 3 entries per table. (I have very
little data in each table, def not splitting yet) But when I visited the UI it showed just
one region per table...
> This patch also addes some toStrings that helped in diagnostics, and a new null check
that I found I needed in IndexedTableScanner

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message