hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Holstad (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (HBASE-880) Improve the current client API by creating new container classes
Date Wed, 22 Oct 2008 16:01:48 GMT

    [ https://issues.apache.org/jira/browse/HBASE-880?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12641095#action_12641095
] 

erikholstad@gmail.com edited comment on HBASE-880 at 10/22/08 9:01 AM:
--------------------------------------------------------------

I think it looks good, and that it is going the right way.
I do have one request though, would be nice to have a put constructor 
that takes the return format from the get as an argument, so you don't
have to change them yourself.

Erik

      was (Author: erikholstad@gmail.com):
    I think it look good, and that it is going the right way.
I do have one request though, would be nice to have a put constructor 
that takes the return format from the get as an argument, so you don't
have to change them yourself.

Erik
  
> Improve the current client API by creating new container classes
> ----------------------------------------------------------------
>
>                 Key: HBASE-880
>                 URL: https://issues.apache.org/jira/browse/HBASE-880
>             Project: Hadoop HBase
>          Issue Type: Improvement
>          Components: client
>            Reporter: Jean-Daniel Cryans
>            Assignee: Jean-Daniel Cryans
>             Fix For: 0.19.0
>
>         Attachments: hbase-880-patch.jpg, hbase-880-proposal4.patch, hbase-880-v1.patch,
hbase-880-v2.patch, hbase_client_classes.png, NewCilentAPIProposoal4.gif, proposal2.jpg, proposed.jpg
>
>
> The current API does not scale very well. For each new feature, we have to add many methods
to take care of all the overloads. Also, the need to batch row operations (gets, inserts,
deletes) implies that we have to manage some "entities" like we are able to do with BatchUpdate
but not with the other operations. The RowLock should be an attribute of such an entity.
> The scope of this jira is only to replace current API with another feature-compatible
one, other methods will be added in other issues.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message