hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Gray (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-877) HCM is unable to find table with multiple regions which contains binary
Date Tue, 09 Sep 2008 13:09:44 GMT

    [ https://issues.apache.org/jira/browse/HBASE-877?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12629484#action_12629484
] 

Jonathan Gray commented on HBASE-877:
-------------------------------------

Definitely seeing same issue as I did with previous versions.  I can still scan META and ROOT,
but after my scan of 'items' broke down I'm not unable to scan any of my other tables from
the shell.

Getting an HTable reference to _any_ table does not work from my java client code.

As before, restarting HBase does fix things.

> HCM is unable to find table with multiple regions which contains binary
> -----------------------------------------------------------------------
>
>                 Key: HBASE-877
>                 URL: https://issues.apache.org/jira/browse/HBASE-877
>             Project: Hadoop HBase
>          Issue Type: Bug
>    Affects Versions: 0.2.1, 0.18.0
>            Reporter: Jonathan Gray
>            Assignee: Jonathan Gray
>            Priority: Blocker
>             Fix For: 0.2.1, 0.18.0
>
>         Attachments: hbase-877-v1.patch, hbase-877-v2.patch, hbase-877-v3.patch, hbase-877-v4.patch,
hbase-877-v5.patch, hbase-877-v6.patch, hbase-877-v8.patch, hbase-877-v9.patch
>
>
> HCM can not find the table with exception:
> org.apache.hadoop.hbase.TableNotFoundException: items
>         at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegionInMeta(HConnectionManager.java:508)
>         at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:460)
>         at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:420)
>         at org.apache.hadoop.hbase.client.HTable.<init>(HTable.java:130)
>         at HBaseRef.<init>(HBaseRef.java:29)
>         at Import.<init>(Import.java:20)
>         at Import.main(Import.java:26)
> I have a fix already for this.  But the problem re-appeared after some time.  I have
no recreated it yet, but will post results in the morning.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message