hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Kellerman (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-905) Remove V5 migration classes from 0.19.0
Date Fri, 26 Sep 2008 22:21:44 GMT

    [ https://issues.apache.org/jira/browse/HBASE-905?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12635048#action_12635048
] 

Jim Kellerman commented on HBASE-905:
-------------------------------------

Can we make package.html more generic and move it up to org.apache.hadoop.hbase.util.migrate?

I think we should leave TestMigrate, although maybe change its name so it isn't run as a test.
What's left are some really useful utility methods that we might need in some future migration
test.

+1 on adding links to messages.

I'll update the Wiki when this gets committed.

> Remove V5 migration classes from 0.19.0
> ---------------------------------------
>
>                 Key: HBASE-905
>                 URL: https://issues.apache.org/jira/browse/HBASE-905
>             Project: Hadoop HBase
>          Issue Type: Task
>          Components: util
>            Reporter: Jim Kellerman
>            Assignee: Jim Kellerman
>             Fix For: 0.19.0
>
>         Attachments: hbase-905-v1.patch
>
>
> The V5 migration package was needed to migrate from hbase-0.1.x to hbase-0.2.x (and also
can migrate from 0.1 to 0.18.x)
> As migration is very complex, if a migration is needed to 0.19 or a future release, removing
these classes and modifying the migration too to not require them will simplify future migrations.
> A note will be placed on the Wiki notifying users that if they need to migrate from 0.1
to 0.19 (or greater), they must first install 0.2.x or 0.18.x, run the migration, and then
install the new version to migrate to it.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message