hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Kellerman (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HBASE-843) Deleting and recreating a table in a single process does not work
Date Mon, 25 Aug 2008 19:19:44 GMT

     [ https://issues.apache.org/jira/browse/HBASE-843?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Jim Kellerman updated HBASE-843:

    Resolution: Fixed
        Status: Resolved  (was: Patch Available)

Committed to branch and trunk. Thanks for the patch Jonathan!

> Deleting and recreating a table in a single process does not work
> -----------------------------------------------------------------
>                 Key: HBASE-843
>                 URL: https://issues.apache.org/jira/browse/HBASE-843
>             Project: Hadoop HBase
>          Issue Type: Bug
>    Affects Versions: 0.2.1, 0.18.0
>            Reporter: Jonathan Gray
>            Assignee: Jonathan Gray
>             Fix For: 0.2.1, 0.18.0
>         Attachments: hbase-843-v1.patch
> When you delete and then recreate/enable the same table in the same process, when you
get the HTable reference to the new table you are actually given the old table.
> The connection information is never deleted/invalidated.
> To fix, we add a call to HConnectionManager.deleteConnectionInfo(conf) at the end of
HBaseAdmin.deleteTable().  This information will then be re-loaded with the latest table references
once the client asks for it.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message