hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Gray (JIRA)" <j...@apache.org>
Subject [jira] Assigned: (HBASE-843) Deleting and recreating a table in a single process does not work
Date Mon, 25 Aug 2008 18:45:44 GMT

     [ https://issues.apache.org/jira/browse/HBASE-843?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Gray reassigned HBASE-843:
-----------------------------------

    Assignee: Jonathan Gray

> Deleting and recreating a table in a single process does not work
> -----------------------------------------------------------------
>
>                 Key: HBASE-843
>                 URL: https://issues.apache.org/jira/browse/HBASE-843
>             Project: Hadoop HBase
>          Issue Type: Bug
>    Affects Versions: 0.2.1, 0.18.0
>            Reporter: Jonathan Gray
>            Assignee: Jonathan Gray
>
> When you delete and then recreate/enable the same table in the same process, when you
get the HTable reference to the new table you are actually given the old table.
> The connection information is never deleted/invalidated.
> To fix, we add a call to HConnectionManager.deleteConnectionInfo(conf) at the end of
HBaseAdmin.deleteTable().  This information will then be re-loaded with the latest table references
once the client asks for it.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message