hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan Smith (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HBASE-828) HBaseAdmin.tableExists(new Text("myTable")) returns false when the table is initially created using HBaseAdmin.createTable
Date Wed, 13 Aug 2008 18:28:44 GMT

     [ https://issues.apache.org/jira/browse/HBASE-828?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ryan Smith updated HBASE-828:
-----------------------------

    Description: 
I was using HBaseAdmin to manage the creation and deletion of tables.  on 0.2.x i noticed
that tableExists returns false even when the table exists.  This seems to be related to the
fact that the tableitself was created using HBaseAdmin createTable.   

Maybe someone else could verify this bug with a simple test.

Process:

One the 1st MR job, i use tableExists(Text) & tableCreate to create the table.

On the 2nd MR job, I call tableExists(Text), which returns false, then i call disableTable,
deleteTable, and finally createTable.

  was:
I was using HBaseAdmin to manage the creation and deletion of tables.  on 0.2.x i noticed
that tableExists returns false even when the table exists.  This seems to be related to the
fact that the tableitself was created using HBaseAdmin createTable.   

Maybe someone else could verify this bug with a simple test.


> HBaseAdmin.tableExists(new Text("myTable")) returns false when the table is initially
created using HBaseAdmin.createTable
> --------------------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-828
>                 URL: https://issues.apache.org/jira/browse/HBASE-828
>             Project: Hadoop HBase
>          Issue Type: Bug
>          Components: util
>    Affects Versions: 0.2.0
>            Reporter: Ryan Smith
>             Fix For: 0.3.0
>
>
> I was using HBaseAdmin to manage the creation and deletion of tables.  on 0.2.x i noticed
that tableExists returns false even when the table exists.  This seems to be related to the
fact that the tableitself was created using HBaseAdmin createTable.   
> Maybe someone else could verify this bug with a simple test.
> Process:
> One the 1st MR job, i use tableExists(Text) & tableCreate to create the table.
> On the 2nd MR job, I call tableExists(Text), which returns false, then i call disableTable,
deleteTable, and finally createTable.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message