hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stack <st...@duboce.net>
Subject Re: Naming patches
Date Wed, 30 Jul 2008 04:17:50 GMT
Would suggest you add below to our 'how to contribute'.

Other comments inline:

Jim Kellerman wrote:
> Several people, myself included, have become confused trying to decide which patch to
test for an issue when multiple versions of the patch have been uploaded to Jira and each
patch has a different name.
> Please try to follow the following naming conventions when uploading a patch:
> hbase-<version_patch_applies_to>-<jira_number>.patch
IMO, in above, 'hbase' is redundant so why not make it optional?  If 
absent, the 'version patch applies to' can't it assumed to be trunk?  
JIRA number, I agree should be required.
> For example the latest patch for HBASE-766 would be named:
> hbase-0.2.0-766.patch
> If there is a subsequent revision to a patch, please name it the same thing. Jira will
show the most recent one at the top of the list.
IMO this is confusing (Do I pull from the top or from the bottom of the 
list of patches?).  I like adding version to patch name.  Something like 
v2, v3, etc.

> Finally, if you want your patch reviewed, mark the Jira issue as patch available. Then
it will show up in the patch review queue:
> https://issues.apache.org/jira/secure/IssueNavigator.jspa?mode=hide&requestId=12312392
> ---
> Jim Kellerman, Senior Engineer; Powerset

View raw message