hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Kellerman (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-584) Names in the filter interface are confusing
Date Tue, 22 Apr 2008 19:07:26 GMT

    [ https://issues.apache.org/jira/browse/HBASE-584?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12591410#action_12591410
] 

Jim Kellerman commented on HBASE-584:
-------------------------------------

I follow Stack's reasoning on this so we can do the patch as-is.

> Names in the filter interface are confusing
> -------------------------------------------
>
>                 Key: HBASE-584
>                 URL: https://issues.apache.org/jira/browse/HBASE-584
>             Project: Hadoop HBase
>          Issue Type: Improvement
>          Components: filters
>            Reporter: Clint Morgan
>            Assignee: Clint Morgan
>            Priority: Minor
>         Attachments: hbase-584.patch
>
>
> I don't like the names of the filter methods in RowFilterInterface. They don't really
tell how the methods are being used in the implementation of scanners.
> I'd like to change:
>  - filter(Text) to filterRow(...)
>  - filter(Text, Text, byte[]) to filterColumn(...)
>   and the worst one is
>  - filterNotNull(SortedMap<Text, byte[]>). This should be filterRow(Text, SortedMap<Text,
byte[]>) (so we add the row key/).
> It may be nice to have timestamps in the methods as well? 
> Also the java doc could be cleaned and improved to tell how the filtering is implemented
(check rows keys first, then check each individual columns, finally check the assembled row)
> Upon positive feedback, and I'll create a patch.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message