hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rong-En Fan (JIRA)" <j...@apache.org>
Subject [jira] Created: (HBASE-573) HBase does not read hadoop-*.xml for dfs configuration after moving out hadoop/contrib
Date Fri, 11 Apr 2008 04:34:04 GMT
HBase does not read hadoop-*.xml for dfs configuration after moving out hadoop/contrib
--------------------------------------------------------------------------------------

                 Key: HBASE-573
                 URL: https://issues.apache.org/jira/browse/HBASE-573
             Project: Hadoop HBase
          Issue Type: Bug
    Affects Versions: 0.1.0
            Reporter: Rong-En Fan
            Priority: Blocker


When HBase was in hadoop/contrib, the hbase script set both HADOOP_CONF_DIR
and HBASE_CONF_DIR to CLASSPATH, so that dfs's configuration can be loaded
correctly. However, when moved out hadoop/contrib, it only sets HBASE_CONF_DIR.

I can think of several possible solutions:

1) set HADOOP_CONF_DIR in hbase-env.sh, then add HADOOP_CONF_DIR to CLASSPATH as before
2) Instruct user to create links for hadoop-*.xml if they want to customize some dfs settings.
3) If only a small set of dfs confs are related to dfs's client, maybe they can be set via
 hbase-site.xml, then hbase sets these for us when create a FileSystem obj.

Please see the thread "# of dfs replications when using hbase" on hbase-user@.



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message