hbase-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zhang...@apache.org
Subject [hbase] branch branch-1 updated: HBASE-22506 Backport HBASE-22500 'Modify pom and jenkins jobs for hadoop versions' to branch-1
Date Mon, 03 Jun 2019 02:22:23 GMT
This is an automated email from the ASF dual-hosted git repository.

zhangduo pushed a commit to branch branch-1
in repository https://gitbox.apache.org/repos/asf/hbase.git


The following commit(s) were added to refs/heads/branch-1 by this push:
     new 8ef2fff  HBASE-22506 Backport HBASE-22500 'Modify pom and jenkins jobs for hadoop
versions' to branch-1
8ef2fff is described below

commit 8ef2fff2c159d3e00ed784265f59eff51e79e197
Author: zhangduo <zhangduo@apache.org>
AuthorDate: Fri May 31 21:55:40 2019 +0800

    HBASE-22506 Backport HBASE-22500 'Modify pom and jenkins jobs for hadoop versions' to
branch-1
    
    Signed-off-by: Andrew Purtell <apurtell@apache.org>
---
 dev-support/hbase-personality.sh | 18 ++++++++++++++++--
 pom.xml                          |  2 +-
 2 files changed, 17 insertions(+), 3 deletions(-)

diff --git a/dev-support/hbase-personality.sh b/dev-support/hbase-personality.sh
index c8db12f..9ec15ab 100755
--- a/dev-support/hbase-personality.sh
+++ b/dev-support/hbase-personality.sh
@@ -514,12 +514,26 @@ function hadoopcheck_rebuild
     if [[ "${QUICK_HADOOPCHECK}" == "true" ]]; then
       hbase_hadoop2_versions="2.8.5 2.9.2"
     else
-      hbase_hadoop2_versions="2.8.2 2.8.3 2.8.4 2.8.5 2.9.1 2.9.2"
+      hbase_hadoop2_versions="2.8.5 2.9.2"
     fi
   fi
-  hbase_hadoop3_versions="3.0.0"
   if [[ "${PATCH_BRANCH}" = branch-1* ]]; then
+    yetus_info "Setting Hadoop 3 versions to test based on branch-1.x rules."
     hbase_hadoop3_versions=""
+  elif [[ "${PATCH_BRANCH}" = branch-2.0 ]] || [[ "${PATCH_BRANCH}" = branch-2.1 ]]; then
+    yetus_info "Setting Hadoop 3 versions to test based on branch-2.0/branch-2.1 rules"
+    if [[ "${QUICK_HADOOPCHECK}" == "true" ]]; then
+      hbase_hadoop3_versions="3.0.3 3.1.2"
+    else
+      hbase_hadoop3_versions="3.0.3 3.1.1 3.1.2"
+    fi
+  else
+    yetus_info "Setting Hadoop 3 versions to test based on branch-2.2+/master/feature branch
rules"
+    if [[ "${QUICK_HADOOPCHECK}" == "true" ]]; then
+      hbase_hadoop3_versions="3.1.2"
+    else
+      hbase_hadoop3_versions="3.1.1 3.1.2"
+    fi
   fi
 
   export MAVEN_OPTS="${MAVEN_OPTS}"
diff --git a/pom.xml b/pom.xml
index 4f5512e..8fb4518 100644
--- a/pom.xml
+++ b/pom.xml
@@ -1252,7 +1252,7 @@
     <hadoop-two.version>2.8.5</hadoop-two.version>
     <!-- minikdc introduced in hadoop-2.3; override when building earlier versions -->
     <hadoop-two-minikdc.version>${hadoop-two.version}</hadoop-two-minikdc.version>
-    <hadoop-three.version>3.0.0</hadoop-three.version>
+    <hadoop-three.version>3.1.2</hadoop-three.version>
     <!-- These must be defined here for downstream build tools that don't look at profiles.
          They ought to match the values found in our default hadoop profile, which is
          currently "hadoop-2.0". See HBASE-15925 for more info. -->


Mime
View raw message