hbase-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From st...@apache.org
Subject [hbase] 01/02: HBASE-21988 Remove hadoop2.6.1-hadoop-2.6.4 as supported on branch-2.0
Date Mon, 04 Mar 2019 20:45:39 GMT
This is an automated email from the ASF dual-hosted git repository.

stack pushed a commit to branch branch-2.0
in repository https://gitbox.apache.org/repos/asf/hbase.git

commit 6e862c2c6098371da50215f761ee514e26e4fd53
Author: stack <stack@apache.org>
AuthorDate: Mon Mar 4 11:31:23 2019 -0800

    HBASE-21988 Remove hadoop2.6.1-hadoop-2.6.4 as supported on branch-2.0
    
    Remove support for versions of hadoop before 2.6.5 on branch-2.0.
    
    Update the matrix in refguide and remove testing earlier versions from
    yetus hbase personality.
---
 dev-support/hbase-personality.sh               | 2 +-
 src/main/asciidoc/_chapters/configuration.adoc | 3 ++-
 2 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/dev-support/hbase-personality.sh b/dev-support/hbase-personality.sh
index ba5bc37..aff386c 100755
--- a/dev-support/hbase-personality.sh
+++ b/dev-support/hbase-personality.sh
@@ -488,7 +488,7 @@ function hadoopcheck_rebuild
 
   # All supported Hadoop versions that we want to test the compilation with
   # See the Hadoop section on prereqs in the HBase Reference Guide
-  hbase_common_hadoop2_versions="2.6.1 2.6.2 2.6.3 2.6.4 2.6.5 2.7.1 2.7.2 2.7.3 2.7.4"
+  hbase_common_hadoop2_versions="2.6.5 2.7.1 2.7.2 2.7.3 2.7.4"
   if [[ "${PATCH_BRANCH}" = branch-1* ]]; then
     yetus_info "Setting Hadoop versions to test based on branch-1-ish rules."
     if [[ "${QUICK_HADOOPCHECK}" == "true" ]]; then
diff --git a/src/main/asciidoc/_chapters/configuration.adoc b/src/main/asciidoc/_chapters/configuration.adoc
index 6980a26..bdbaafb 100644
--- a/src/main/asciidoc/_chapters/configuration.adoc
+++ b/src/main/asciidoc/_chapters/configuration.adoc
@@ -223,7 +223,8 @@ Use the following legend to interpret this table:
 |Hadoop-2.4.x | S | S | X | X | X
 |Hadoop-2.5.x | S | S | X | X | X
 |Hadoop-2.6.0 | X | X | X | X | X
-|Hadoop-2.6.1+ | S | S | X | S | X
+|Hadoop-2.6.1+ | S | S | X | X | X
+|Hadoop-2.6.5+ | S | S | X | S | X
 |Hadoop-2.7.0 | X | X | X | X | X
 |Hadoop-2.7.1+ | S | S | S | S | S
 |Hadoop-2.8.[0-1] | X | X | X | X | X


Mime
View raw message