hbase-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bus...@apache.org
Subject [4/4] hbase git commit: HBASE-15925 provide default values for hadoop compat module related properties that match default hadoop profile.
Date Thu, 09 Jun 2016 21:56:48 GMT
HBASE-15925 provide default values for hadoop compat module related properties that match default
hadoop profile.

Signed-off-by: Mikhail Antonov <antonov@apache.org>


Project: http://git-wip-us.apache.org/repos/asf/hbase/repo
Commit: http://git-wip-us.apache.org/repos/asf/hbase/commit/737b1d6d
Tree: http://git-wip-us.apache.org/repos/asf/hbase/tree/737b1d6d
Diff: http://git-wip-us.apache.org/repos/asf/hbase/diff/737b1d6d

Branch: refs/heads/branch-1.1
Commit: 737b1d6def1084c731a64ce9c1e14c7f1d8cbf8a
Parents: bccedc6
Author: Sean Busbey <busbey@apache.org>
Authored: Thu Jun 9 13:30:45 2016 -0500
Committer: Sean Busbey <busbey@apache.org>
Committed: Thu Jun 9 16:53:18 2016 -0500

----------------------------------------------------------------------
 pom.xml | 7 +++++++
 1 file changed, 7 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/hbase/blob/737b1d6d/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index f9a485d..1c199b0 100644
--- a/pom.xml
+++ b/pom.xml
@@ -1144,6 +1144,13 @@
     <!-- minikdc introduced in hadoop-2.3; override when building earlier versions -->
     <hadoop-two-minikdc.version>${hadoop-two.version}</hadoop-two-minikdc.version>
     <hadoop-three.version>3.0.0-SNAPSHOT</hadoop-three.version>
+    <!-- These must be defined here for downstream build tools that don't look at profiles.
+         They ought to match the values found in our default hadoop profile, which is
+         currently "hadoop-2.0". See HBASE-15925 for more info. -->
+    <hadoop.version>${hadoop-two.version}</hadoop.version>
+    <compat.module>hbase-hadoop2-compat</compat.module>
+    <assembly.file>src/main/assembly/hadoop-two-compat.xml</assembly.file>
+    <!-- end HBASE-15925 default hadoop compatibility values -->
     <commons-cli.version>1.2</commons-cli.version>
     <commons-codec.version>1.9</commons-codec.version>
     <!-- pretty outdated -->


Mime
View raw message