hbase-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bus...@apache.org
Subject hbase git commit: HBASE-13344 Addendum - Move max Java version check to release.
Date Mon, 01 Jun 2015 14:10:05 GMT
Repository: hbase
Updated Branches:
  refs/heads/master 0e6102a68 -> 9a4ae799c


HBASE-13344 Addendum - Move max Java version check to release.

Signed-off-by: Sean Busbey <busbey@apache.org>


Project: http://git-wip-us.apache.org/repos/asf/hbase/repo
Commit: http://git-wip-us.apache.org/repos/asf/hbase/commit/9a4ae799
Tree: http://git-wip-us.apache.org/repos/asf/hbase/tree/9a4ae799
Diff: http://git-wip-us.apache.org/repos/asf/hbase/diff/9a4ae799

Branch: refs/heads/master
Commit: 9a4ae799c7314b36779339178f6fe9800a123d35
Parents: 0e6102a
Author: Matt Warhaftig <mwarhaftig@gmail.com>
Authored: Sun May 31 11:17:23 2015 -0400
Committer: Sean Busbey <busbey@apache.org>
Committed: Sun May 31 23:29:24 2015 -0500

----------------------------------------------------------------------
 pom.xml | 28 ++++++++++++++++++----------
 1 file changed, 18 insertions(+), 10 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/hbase/blob/9a4ae799/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index 3e53403..a45e745 100644
--- a/pom.xml
+++ b/pom.xml
@@ -834,16 +834,6 @@
   See the reference guide on building for more information: http://hbase.apache.org/book.html#build
               </message>
             </requireJavaVersion>
-            <enforceBytecodeVersion>
-              <maxJdkVersion>${compileSource}</maxJdkVersion>
-              <message>HBase has unsupported dependencies.
-  HBase requires that all dependencies be compiled with version ${compileSource} or earlier
-  of the JDK to properly build from source.  You appear to be using a newer dependency. You
can use
-  either "mvn -version" or "mvn enforcer:display-info" to verify what version is active.
-  Non-release builds can temporarily build with a newer JDK version by setting the
-  'compileSource' property (eg. mvn -DcompileSource=1.8 clean package).
-              </message>
-            </enforceBytecodeVersion>
           </rules>
         </configuration>
         <executions>
@@ -1875,6 +1865,24 @@
               </execution>
             </executions>
           </plugin>
+          <plugin>
+            <groupId>org.apache.maven.plugins</groupId>
+            <artifactId>maven-enforcer-plugin</artifactId>
+            <configuration>
+              <rules>
+                <enforceBytecodeVersion>
+                <maxJdkVersion>${compileSource}</maxJdkVersion>
+                <message>HBase has unsupported dependencies.
+  HBase requires that all dependencies be compiled with version ${compileSource} or earlier
+  of the JDK to properly build from source.  You appear to be using a newer dependency. You
can use
+  either "mvn -version" or "mvn enforcer:display-info" to verify what version is active.
+  Non-release builds can temporarily build with a newer JDK version by setting the
+  'compileSource' property (eg. mvn -DcompileSource=1.8 clean package).
+                </message>
+              </enforceBytecodeVersion>
+            </rules>
+          </configuration>
+          </plugin>
         </plugins>
       </build>
     </profile>


Mime
View raw message