hbase-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From st...@apache.org
Subject svn commit: r966661 - in /hbase/trunk: CHANGES.txt pom.xml
Date Thu, 22 Jul 2010 14:01:57 GMT
Author: stack
Date: Thu Jul 22 14:01:57 2010
New Revision: 966661

URL: http://svn.apache.org/viewvc?rev=966661&view=rev
Log:
HBASE-2850 slf4j version needs to be reconciled in pom: thrift wants 1.5.x and hadoop/avro
1.4.x

Modified:
    hbase/trunk/CHANGES.txt
    hbase/trunk/pom.xml

Modified: hbase/trunk/CHANGES.txt
URL: http://svn.apache.org/viewvc/hbase/trunk/CHANGES.txt?rev=966661&r1=966660&r2=966661&view=diff
==============================================================================
--- hbase/trunk/CHANGES.txt (original)
+++ hbase/trunk/CHANGES.txt Thu Jul 22 14:01:57 2010
@@ -788,6 +788,8 @@ Release 0.21.0 - Unreleased
                and other helper classes
    HBASE-2845  Small edit of shell main help page cutting down some on white
                space and text
+   HBASE-2850  slf4j version needs to be reconciled in pom: thrift wants 1.5.x
+               and hadoop/avro 1.4.x
 
   NEW FEATURES
    HBASE-1961  HBase EC2 scripts

Modified: hbase/trunk/pom.xml
URL: http://svn.apache.org/viewvc/hbase/trunk/pom.xml?rev=966661&r1=966660&r2=966661&view=diff
==============================================================================
--- hbase/trunk/pom.xml (original)
+++ hbase/trunk/pom.xml Thu Jul 22 14:01:57 2010
@@ -582,21 +582,6 @@
       <groupId>log4j</groupId>
       <artifactId>log4j</artifactId>
     </dependency>
-
-    <!--
-      This is highly dubious!
-
-      We need SLF4J >= 1.5.6 and Thrift depends on that version.
-      hadoop-core on the other hand depends on SLF4J 1.4.3 (even though it is optional)
-      and Mavens dependency resolution mechanism choses the 'nearest' dependency in case
-      of a conflict of dependencies on the same level. The nearest is always the one
-      that was defined first in the pom:
-      http://maven.apache.org/guides/introduction/introduction-to-dependency-mechanism.html
-
-      That's why we've added an explicit dependency to SFL4J-API even though we don't need
it.
-      Make sure to check the version of SLF4J Hadoop and Thrift depend on when you upgrade
-      one of them.
-    -->
     <dependency>
       <groupId>org.apache.thrift</groupId>
       <artifactId>thrift</artifactId>
@@ -724,7 +709,7 @@
     <dependency>
       <groupId>org.slf4j</groupId>
       <artifactId>slf4j-log4j12</artifactId>
-      <version>1.4.3</version>
+      <version>${slf4j.version}</version>
     </dependency>
     <dependency>
       <groupId>org.apache.hadoop</groupId>
@@ -734,7 +719,7 @@
     <dependency>
       <groupId>org.slf4j</groupId>
       <artifactId>slf4j-api</artifactId>
-      <version>1.4.3</version>
+      <version>${slf4j.version}</version>
     </dependency>
     <dependency>
       <groupId>org.codehaus.jackson</groupId>



Mime
View raw message