hawq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wangzw <...@git.apache.org>
Subject [GitHub] incubator-hawq pull request #1376: [RFC] Changed libhdfs3 to be ABI compatib...
Date Fri, 15 Jun 2018 02:45:49 GMT
Github user wangzw commented on a diff in the pull request:

    https://github.com/apache/incubator-hawq/pull/1376#discussion_r195622167
  
    --- Diff: depends/libhdfs3/src/client/Hdfs.cpp ---
    @@ -35,6 +35,7 @@
     #include "Thread.h"
     #include "XmlConfig.h"
     
    +#include <boost/scope_exit.hpp>
    --- End diff --
    
    Do not make boost as hard requirement. libhdfs3 only needs boost if you are using an old
version compiler such as GCC 4.4.
    
    If the function provided by boost is not in the standard c++ library, do not use such
function.



---

Mime
View raw message