hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lav Jain <lj...@pivotal.io>
Subject Re: Support Matrix for HAWQ
Date Tue, 29 Jan 2019 23:52:06 GMT
I believe you need to
modify ambari-server/src/main/resources/common-services/HAWQ/2.0.0/metainfo.xml

      <osSpecifics>
        <osSpecific>
          <osFamily>any</osFamily>
          <packages>
            <package>
              <name>hawq</name>
            </package>
          </packages>
        </osSpecific>
      </osSpecifics>

Regards,


*Lav Jain*
*Pivotal Data*

ljain@pivotal.io


On Tue, Jan 29, 2019 at 3:10 PM Harald Bögeholz
<harald.boegeholz@monash.edu.invalid> wrote:

> Am 29.01.19 um 17:51 schrieb shenxl:
> > Hi Harald,
> >
> > the HAWQ Ambari plugin isn’t included in HAWQ binary distribition,  you
> can get the plugin at .
> > https://github.com/apache/hawq/tree/master/contrib/hawq-ambari-plugin <
> https://github.com/apache/hawq/tree/master/contrib/hawq-ambari-plugin>.
>
> Thank you for your help.
>
> I managed to install the Ambari plugin and setup a repository for the
> HAWQ binaries.
>
> Now deployment fails with this error:
>
> resource_management.core.exceptions.ExecutionFailed: Execution of
> '/usr/bin/yum -d 0 -e 0 -y install hawq' returned 1. Error: Nothing to do
>
> I think it is because it should be yum install apache-hawq, but I don't
> know where to change this.
>
> Could I get another hint?
>
> Thanks
> Harald
>
> >
> >> ---------- Forwarded message ---------
> >> From: Harald Bögeholz <harald.boegeholz@monash.edu.invalid>
> >> Date: 2019年1月29日周二 上午9:32
> >> Subject: Re: Support Matrix for HAWQ
> >> To: <dev@hawq.apache.org <mailto:dev@hawq.apache.org>>
> >>
> >>
> >> Am 23.01.19 um 15:01 schrieb Ruilong Huo:
> >>> Hi Harald,
> >>>
> >>>
> >>> If you prefer to use binary, you can get 2.4 release binary at
> http://hawq.apache.org/#download <http://hawq.apache.org/#download>
> >>> For the support matrix, it works with RHEL 6.4+/7.2+ x86_64, HDP
> 2.5.3/2.6.1, and Ambari 2.4.2, 2.5.1.
> >>
> >> I have a Hadoop cluster using HDP 2.6.1/Ambari 2.5.1 up and running now.
> >>
> >> The HAWQ binary distribition doesn't seem to include the Ambari plugin,
> >> though.
> >>
> >> So I'm stuck and don't know how to deploy HAWQ.
> >>
> >> Could somebody point me to the right instructions?
> >>
> >>
> >> Thanks
> >> Harald
> >>
> >>>
> >>>
> >>> Best regards,
> >>> Ruilong Huo
> >>> At 2019-01-23 09:35:21, "Harald Bögeholz" <harald.boegeholz@monash.edu
> <mailto:harald.boegeholz@monash.edu>.INVALID> wrote:
> >>>> Hello,
> >>>>
> >>>>
> >>>> I have seen this discussion and I'm a bit confused. I'm about to
> setup a
> >>>> new Hadoop cluster to run HAWQ on CentOS 7.
> >>>>
> >>>> What's the best way to get this up and running?
> >>>>
> >>>> I was thinking about starting with Hortonworks HDP. Which exact
> version
> >>>> should I use? I can't simply use the latest one?
> >>>>
> >>>> When I have Hadoop running, can I deploy HAWQ using Ambari? I looked
> in
> >>>> the HAWQ wiki and there are instructions for compiling HAWQ, but I was
> >>>> hoping to be able to just drop the binaries somewhere for Ambari to
> >>>> deploy them?
> >>>>
> >>>>
> >>>> Thanks for any help
> >>>> Harald
> >>>>
> >>>>
> >>>> Am 23.01.19 um 12:00 schrieb Yi JIN:
> >>>>> Hi Timo,
> >>>>>
> >>>>> Yes, this is planned in version 2.5. The issue for tracking this
is
> going
> >>>>> to be added into the release schedule. I checked this with release
> manager
> >>>>> for this requirement. Thanks.
> >>>>>
> >>>>> Best,
> >>>>> Yi
> >>>>>
> >>>>> On Tue, Jan 15, 2019 at 8:20 PM Timo Burmeister <
> Timo.Burmeister@freenet.ag <mailto:Timo.Burmeister@freenet.ag>>
> >>>>> wrote:
> >>>>>
> >>>>>> Hi Yi,
> >>>>>>
> >>>>>> do you think for HDP 3 we have to wait for Apache HAWQ 2.5?
> >>>>>>
> >>>>>> Best,
> >>>>>>
> >>>>>> Timo
> >>>>>>
> >>>>>>
> >>>>>> i.V. Timo Burmeister
> >>>>>>
> >>>>>> Head of Innovationsmanagement
> >>>>>> IT-Strategy & New Technologies
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>> freenet AG
> >>>>>> Deelbögenkamp 4c
> >>>>>> D-22297 Hamburg
> >>>>>>
> >>>>>> Tel.: +49 (0) 4051306619
> >>>>>> Fax: +49 (0) 4051306659
> >>>>>>
> >>>>>> timo.burmeister@freenet.ag <mailto:timo.burmeister@freenet.ag>
> >>>>>>
> >>>>>> www.mobilcom-debitel.de <http://www.mobilcom-debitel.de/>
<
> http://www.mobilcom-debitel.de <http://www.mobilcom-debitel.de/>>
> >>>>>> www.freenet.de <http://www.freenet.de/> <http://www.freenet.de
<
> http://www.freenet.de/>>
> >>>>>> www.freenet-group.de <http://www.freenet-group.de/> <
> http://www.freenet-group.de <http://www.freenet-group.de/>>
> >>>>>>
> >>>>>> Vorstand: Christoph Vilanek (Vorsitzender), Ingo Arnold, Stephan
> Esch,
> >>>>>> Antonius Fromme, Rickmann von Platen
> >>>>>> Vorsitzender des Aufsichtsrats: Prof. Dr. Helmut Thoma
> >>>>>> Sitz der Gesellschaft: Büdelsdorf
> >>>>>> HRB 7306 KI, Amtsgericht Kiel
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>> +++ freenet Group - EINE GRUPPE. ALLE MÖGLICHKEITEN - Hier
<
> >>>>>> https://stellenangebote.freenet-group.de/ <
> https://stellenangebote.freenet-group.de/>> suchen wir noch Verstärkung!
> >>>>>> +++
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>> Am 15.01.19, 04:07 schrieb "Yi JIN" <yjin@apache.org <mailto:
> yjin@apache.org>>:
> >>>>>>
> >>>>>>     Hi Timo,
> >>>>>>
> >>>>>>     I think HAWQ 2.4 supports HDP 2.6.1 and 2.5.3.
> >>>>>>
> >>>>>>     Best,
> >>>>>>
> >>>>>>     Yi
> >>>>>>
> >>>>>>     On Sat, Dec 22, 2018 at 2:55 AM Timo Burmeister <
> >>>>>> Timo.Burmeister@freenet.ag <mailto:Timo.Burmeister@freenet.ag>>
> >>>>>>     wrote:
> >>>>>>
> >>>>>>     > Hi !
> >>>>>>     >
> >>>>>>     > Where can I find the supported Hadoop Version for the
new
> Apache
> >>>>>> HAWQ 2.4
> >>>>>>     > Release?
> >>>>>>     >
> >>>>>>     > Does Apache HAWQ 2.4 support HDP 2.6 and HDP 3.0.1
?
> >>>>>>     >
> >>>>>>     > Best regards
> >>>>>>     > Timo
> >>>>>>     >
> >>>>>>     >
> >>>>>>     >
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>
> >
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message