hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "xinzhang (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HAWQ-1568) install " pxf-hdfs-3.2.1.0-1.el6.noarch.rpm" dependencies pro?
Date Wed, 06 Dec 2017 07:56:00 GMT
xinzhang created HAWQ-1568:
------------------------------

             Summary: install " pxf-hdfs-3.2.1.0-1.el6.noarch.rpm" dependencies pro?
                 Key: HAWQ-1568
                 URL: https://issues.apache.org/jira/browse/HAWQ-1568
             Project: Apache HAWQ
          Issue Type: Bug
            Reporter: xinzhang
            Assignee: Radar Lei


Hi . I install hawq with rpm from 2.2.0 (apache-hawq-2.2.0.0-el7.x86_64.rpm) 
But when I install other rpm (like pxf-hdfs-3.2.1.0-1.el6.noarch.rpm)
----
[gpadmin@gpmaster hawq_rpm_packages]$ rpm -ivh pxf-hdfs-3.2.1.0-1.el6.noarch.rpm
error: Failed dependencies:
	pxf-service >= 3.2.1.0 is needed by pxf-hdfs-0:3.2.1.0-1.el6.noarch
	hadoop >= 2.7.1 is needed by pxf-hdfs-0:3.2.1.0-1.el6.noarch
	hadoop-mapreduce >= 2.7.1 is needed by pxf-hdfs-0:3.2.1.0-1.el6.noarch

I install hadoop with .tar 
------------
[gpadmin@gpmaster hawq_rpm_packages]$ which hadoop 
/opt/hadoop/hadoop-2.9.0/bin/hadoop
[gpadmin@gpmaster hawq_rpm_packages]$ echo $HADOOP_HOME
/opt/hadoop/hadoop-2.9.0

How to let rpm know my Hadoop had installed.




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message