hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shubham Sharma (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HAWQ-1559) Travis CI failing for hawq after travis ci default image upgraded xcode to 8.3
Date Fri, 01 Dec 2017 01:00:00 GMT
Shubham Sharma created HAWQ-1559:
------------------------------------

             Summary: Travis CI failing for hawq after travis ci default image upgraded xcode
to 8.3
                 Key: HAWQ-1559
                 URL: https://issues.apache.org/jira/browse/HAWQ-1559
             Project: Apache HAWQ
          Issue Type: Bug
          Components: Build
            Reporter: Shubham Sharma
            Assignee: Radar Lei


It looks like our Travis build is broken. I first noticed this for my own fork's build and
saw the same behavior in apache github repo as well. It is failing with the error below

{code}
configure: error: Please install apr from http://apr.apache.org/ and add dir of 'apr-1-config'
to env variable '/Users/travis/.rvm/gems/ruby-2.4.2/bin:/Users/travis/.rvm/gems/ruby-2.4.2@global/bin:/Users/travis/.rvm/rubies/ruby-2.4.2/bin:/Users/travis/.rvm/bin:/Users/travis/bin:/Users/travis/.local/bin:/Users/travis/.nvm/versions/node/v6.11.4/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin'.
The command "./configure" failed and exited with 1 during .
Your build has been stopped.
/Users/travis/.travis/job_stages: line 166: shell_session_update: command not found
{code}

Looked into it, the builds started failing November 28th. This is around the same time when
Travis CI upgraded their default xcode version to 8.3. Here is the notification .

Have identified a potential fix and tested it for my fork, the build completes successfully.
Currently we don't install apr using brew install, which is one of the pre-requisites as mentioned
in the hawq incubator wiki. The fix is to "brew install apr" and then force link it to the
path using "brew link apr --force. This resolves the problem.

But I have couple of additional questions - 

1. How did the apr get installed before, was it installed with some other package. Asking
this as few packages have been removed from the default image in xcode 8.3

2. Though the build for branches is failing continuously, why the build status for master
is still green ? 

Anyhow, since apr is a dependency for our project my proposal is to add a brew install to
travis.yml to avoid failure due to such upgrade in future. 

Let me know your thoughts, I have a PR ready.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message