hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Radar Lei <r...@pivotal.io>
Subject Re: Travis CI failing for Hawq
Date Fri, 01 Dec 2017 02:08:43 GMT
Hi Shubham,

Thanks for help addressing this issue. I think you can just go ahead and
fix it.

For the question why master is still green, I think there is no PR was
merged to master in the passed, so only PRs were tested by Travis.

Regards,
Radar

On Fri, Dec 1, 2017 at 3:04 AM, Shubham Sharma <ssharma@pivotal.io> wrote:

> Hello folks,
>
> It looks like our Travis build is broken. I first noticed this for my own
> fork's build and saw the same behavior in apache github repo as well. It is
> failing with the error below
>
> configure: error: Please install apr from http://apr.apache.org/ and
> add dir of 'apr-1-config' to env variable
> '/Users/travis/.rvm/gems/ruby-2.4.2/bin:/Users/travis/.rvm/
> gems/ruby-2.4.2@global/bin:/Users/travis/.rvm/rubies/ruby-
> 2.4.2/bin:/Users/travis/.rvm/bin:/Users/travis/bin:/Users/
> travis/.local/bin:/Users/travis/.nvm/versions/node/v6.
> 11.4/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin'.
>
> The command "./configure" failed and exited with 1 during .
>
> Your build has been stopped.
>
> /Users/travis/.travis/job_stages: line 166: shell_session_update:
> command not found
>
> Looked into it, the builds started failing November 28th. This is around
> the same time when Travis CI upgraded their default xcode version to 8.3.
> Here
> is the notification
> <https://blog.travis-ci.com/2017-11-21-xcode8-3-default-image-announce> .
>
> Have identified a potential fix and tested it for my fork, the build
> completes successfully. Currently we don't install apr using brew install,
> which is one of the pre-requisites as mentioned in the hawq incubator wiki.
> The fix is to "brew install apr" and then force link it to the path using
> "brew link apr --force. This resolves the problem.
>
> But I have couple of additional questions -
>
> 1. How did the apr get installed before, was it installed with some other
> package. Asking this as few packages have been removed from the default
> image in xcode 8.3
>
> 2. Though the build for branches is failing continuously, why the build
> status for master is still green ?
>
> Anyhow, since apr is a dependency for our project my proposal is to add a
> brew install to travis.yml to avoid failure due to such upgrade in future.
>
> Let me know your thoughts, I can create a JIRA and already have a PR ready.
>
> --
> Regards,
> Shubham
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message