hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shubham Sharma <ssha...@pivotal.io>
Subject Re: HAWQ-421 - Proposal to remove references of GPHOME and greenplum_path.sh
Date Wed, 06 Sep 2017 02:50:23 GMT
Hi Radar,

I tried to change these references over the weekend and was able to
successfully compile and install hawq. But as you mentioned this change has
a big impact and needs more thorough testing and is suitable for a major
release version.

Regarding development CI and test cases, I made changes to the dev pipeline
as well to try out this change. The code changed passed the CI pipeline
except some pxf automation test. I could not test those changes as I don't
have access to that repo.

Let's continue this discussion around the major release and I hope this
change makes it way to the next major release.


On Tue, Sep 5, 2017 at 3:07 AM, Radar Lei <rlei@pivotal.io> wrote:

> Hi Shubham,
>
> I would recommend we hold on this change until we have fully understanding
> of the affects and the benefit we can get.
>
> I can think about below items:
>
>    - Require a lot of changes to development CI and Test cases.
>    - Require changes of user defined scripts and cases.
>    - Might affect the user who are using GPDB clients to access HAWQ.
>    - Might affect other projects which are related to HAWQ, e.g. Madlib.
>    - It's better to have such changes at a major release, like 3.0.
>
> So this is my opinion, welcome other comments. Thanks.
>
>
> Regards,
> Radar
>
> On Mon, Sep 4, 2017 at 8:45 AM, Shubham Sharma <ssharma@pivotal.io> wrote:
>
> > Hi,
> >
> > HAWQ-421 describes the confusion created by GPHOME and greenplum_path.sh,
> > which also seems out of place with the project name HAWQ. This issue is
> > marked as backlog for a while and I wanted to take the opportunity to
> > replace these references with something related to our project.
> >
> > Since these changes almost touch the entire project and the naming
> changes
> > will stick going on forward, wanted to bounce off some ideas with the
> > community, let me know which naming convention sounds better.
> >
> > 1 - Replace GPHOME with
> >
> > a - HAWQHOME
> > b - HAWQ_HOME
> > c - HAWQ_CONF_DIR
> >
> > 2 - Replace greenplum_path.sh with
> >
> > a - hawq_env.sh
> > b - hawq_path.sh
> >
> > I prefer 1-b and 2-a
> >
> > Please feel free to add other options. Appreciate your inputs.
> >
> > --
> > Regards,
> > Shubham
> >
>



-- 
Regards,
Shubham Sharma
Staff Customer Engineer
Pivotal Global Support Services
ssharma@pivotal.io
Direct Tel: +1(510)-304-8201
Office Hours: Mon-Fri 9:00 am to 5:00 pm PDT
Out of Office Hours Contact +1 877-477-2269

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message