hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "fangpei (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HAWQ-1471) "Build and Install" under Red Hat 6.X environment, gcc / gcc-c++ version 4.7.2 is too low to install hawq
Date Tue, 23 May 2017 16:31:04 GMT
fangpei created HAWQ-1471:
-----------------------------

             Summary: "Build and Install" under Red Hat 6.X environment, gcc / gcc-c++ version
4.7.2 is too low to install hawq
                 Key: HAWQ-1471
                 URL: https://issues.apache.org/jira/browse/HAWQ-1471
             Project: Apache HAWQ
          Issue Type: Improvement
          Components: Build
            Reporter: fangpei
            Assignee: Ed Espino


    My OS environment is Red Hat 6.5. I referred to the  website "https://cwiki.apache.org//confluence/display/HAWQ/Build+and+Install"
to build and install hawq. I installed the GCC version specified on the website (4.7.2 / gcc-c++
4.7.2), but the error happened:
    "error: 'Hdfs::Internal::Once' cannot be thread-local because it has non-trivial type
'std::once_flag'" 
    or
    "error : 'Yarn:Internal::Once' cannot be thread-local because it has non-trivial type
'std::once_flag'"
    I found that GCC support for C ++ 11 is not good, leading to the emergence of the error.
    So I installed gcc 4.8.5, and the problem was resolved. 
    gcc / gcc-c++ version 4.7.2 is too low to install hawq, I suggest updating the website
about gcc / gcc-c++ version requirement.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message