hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xiang Sheng <xsh...@pivotal.io>
Subject Re: Need help on HAWQ Build
Date Thu, 16 Mar 2017 07:12:32 GMT
Hi Ketan,

Long time ago, someone met the same problem with you. Finally he found it's
a cmake version problem. He resolved this problem by upgrade his cmake >=
3.0.  You could refer to this merged pull request.
https://github.com/apache/incubator-hawq/pull/678.

Suggestion :
Remember to cc the questioner's email when you replied to the thread.
Maybe someone haven't subscribe to the dev list and he cannot received your
helpful steps.

Regards,
Xiang

On Thu, Mar 16, 2017 at 8:35 AM, Paul Guo <paulguo@gmail.com> wrote:

> Hi Ketan,
>
> As Kyle said, we include Google Test in our code, however if we look
> at the Makefile in the root path, i.e. GNUmakefile.in, we build it before
> building other components  automatically.
>
> Generally speaking, to install hawq, you install those dependencies (refer
> the installation
> wiki or contrib/hawq-docker/centos6-docker/hawq-dev/Dockerfile), then
> run configure with your options and then run "make install" in the root
> path,
> and hawq installation will be done.
>
> As to your case, your log is short so I do not know who reports this error,
> but I suspect googletest has not been built or build fails (but if google
> test build
> fails make should exit immediately), so please make sure the first build
> starts at
> the root path and please check google test framework build logs if
> googletest
> build fails (depends/thirdparty/googletest/build/CMakeFiles/*.log).
>
> Regards.
>
>
> 2017-03-15 21:19 GMT+08:00 Ketan Kunde <ketan_kunde@persistent.com>:
>
> > HI,
> >
> > I am building HAWQ on s390x platform.
> > I am referring the below link to build and Install
> > https://cwiki.apache.org/confluence/display/HAWQ/Build+and+Install
> >
> >
> > I have been able to configure the HAWQ
> > I have also started Hadoop hdfs file system
> > But when I start building HAWQ I get stuck at the below test case.
> >
> > - GoogleTest check:
> > CMake Error at /usr/share/cmake-3.3/Modules/
> FindPackageHandleStandardArgs.cmake:148
> > (message):
> >   Could NOT find GoogleTest (missing: GoogleTest_CHECK_FINE)
> > Call Stack (most recent call first):
> >   /usr/share/cmake-3.3/Modules/FindPackageHandleStandardArgs.cmake:388
> > (_FPHSA_FAILURE_MESSAGE)
> >   CMake/FindGoogleTest.cmake:52 (find_package_handle_standard_args)
> >   CMakeLists.txt:23 (FIND_PACKAGE)
> >
> > Can you help me resolve this
> >
> >
> > Regards
> > Ketan
> >
> > DISCLAIMER
> > ==========
> > This e-mail may contain privileged and confidential information which is
> > the property of Persistent Systems Ltd. It is intended only for the use
> of
> > the individual or entity to which it is addressed. If you are not the
> > intended recipient, you are not authorized to read, retain, copy, print,
> > distribute or use this message. If you have received this communication
> in
> > error, please notify the sender and delete all copies of this message.
> > Persistent Systems Ltd. does not accept any liability for virus infected
> > mails.
> >
> >
>



-- 
Best Regards,
Xiang Sheng

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message