hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ed Espino <esp...@apache.org>
Subject Fwd: HEADS UP: PXF fails to build with JDK 1.8
Date Fri, 03 Feb 2017 03:20:01 GMT
Ruilong,

I was simply following instructions on build processes from wiki. I happen
to have Java 8 installed on my Macbook and when building PXF I ran into a
"javadocs" build issue.  This has been fixed by HAWQ-1306 & HAWQ-1308. As
far as I can tell, there wasn't a mention of which java version is
supported on the project's wiki.

Out of curiosity, what are the issues with supporting Java 8 with HAWQ.
Please respond to the question by Alex (Oleksandr) Diachenko posted with
subject "[DISCUSS] Switch HAWQ to Java 8" to the dev email list.

Thanks,
-=e

On Thu, Feb 2, 2017 at 6:26 PM, Ruilong Huo <rhuo@pivotal.io> wrote:

> Hi Ed,
>
> hawq does not support java 1.8 now. Do you mean pxf is adapted to be
> compatible with java 1.7 and 1.8?
>
> Best regards,
> Ruilong Huo
>
> On Thu, Feb 2, 2017 at 1:45 AM, Ed Espino <espino@apache.org> wrote:
>
> > I have filed the following Jira:
> > https://issues.apache.org/jira/browse/HAWQ-1306
> >
> > This was introduced by Alex Diachenko with commit:
> > https://github.com/apache/incubator-hawq/commit/
> > 6fa1ced20e8bb2820b73e6904f77c4b4a1ed6de2
> >
> > -=e
> >
> > --
> > *Ed Espino*
> > *espino@apache.org <espino@apache.org>*
> >
>



-- 
*Ed Espino*
*espino@apache.org <espino@apache.org>*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message