hawq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lili Ma <...@pivotal.io>
Subject Re: HAWQ upgrade command
Date Mon, 13 Feb 2017 02:57:18 GMT
Hi Alex,

Could you tell the original version and to-be-upgraded version of HAWQ, so
that we can try to reproduce it?

Thanks
Lili

On Sat, Feb 11, 2017 at 10:27 AM, Alex (Oleksandr) Diachenko <
odiachenko@pivotal.io> wrote:

> Hi,
>
> I saw HAWQ-1171 was merged to master recently, and I am trying to figure
> out how it works.
> The scripts drops gp_relfile_insert_for_register procedure if it exists and
> creates it again using latest signature.
>
> I tried it out and it worked for me in a case when
> gp_relfile_insert_for_register doesn't exist.
> But in case when gp_relfile_insert_for_register exist I am getting:
>
> *ERROR:  cannot drop function
> gp_relfile_insert_for_register(oid,oid,oid,oid,oid,
> cstring,character,character,oid)
> because it is required by the database system*
>
> Is it even intended to be run when procedure exists? Do I have to set any
> GUCs to make it work?
>
> Regards, Alex.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message